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重要事項
• ヤマハ(株)および第三者から販売もしくは提供されているシーケンスデータおよびデジタルオーディオ/画像/ビデオファイルは、私的使 
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• このソフトウェアおよび取扱説明書の著作権はすべてヤマハ(株)が所有します。

• このソフトウェアおよび取扱説明書の一部または全部を無断で複製、改変することはできません。
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す。また、画面はWindows版をもとに説明していますが、使い方はMac版も同様です。

• Windowsは、米国Microsoft Corporationの米国およびその他の国における登録商標です。

• Apple、Mac、Macintoshは、米国および他の国々で登録されたApple Inc.の商標です。

• MIDIは社団法人音楽電子事業協会(AMEI)の登録商標です。
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はじめに
MIDI Song to Styleとは
MIDI Song to Styleは、MIDIソング (SMF: Standard Midi File (.mid))をスタイルファイル (.sty)に自動変換するアプリ
ケーションです。これにより、自分が弾きたい曲を、楽器上でスタイルとして再生しながら演奏できます。

また、下記のように、変換途中データの試聴や編集ができます。
- 読み込んだMIDIソングの再生、各チャンネルの音色の割り当て変更
- 変換後のスタイルの試聴、編集

アプリケーション使用時の注意事項
• 本アプリケーション(以下、本アプリ)はサービス品質改善のため、また関連製品/サービスのプロモーションのため、機能の
利用状況データを匿名で収集します。編集するデータ自体を収集することはありません。もし利用状況を送信したくない場
合は、Settingから状況収集しないように設定できます(12ページ)。
• 本アプリはMIDIソングからスタイルファイルへの変換が主目的のため、音楽プレイヤーとしての用途は想定されていませ
ん。そのため、アプリ内での下記の試聴機能については、あくまで編集の補助としての役割であり、再生音などの完全な互
換性は保証されません。ご了承ください。
- MIDIソングの再生
- 変換後のスタイルの再生

• SFF GEフォーマット対応機種(Genos2など)のみ、このアプリを使用可能です。

コンピューター

楽器
MIDI Song to Style

MIDIソング
(.mid)

スタイル
(.sty)

USBケーブル接続
での転送
または

USBメモリー経由
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ご使用前の準備
機器の接続と設定
楽器と接続して使う場合と、コンピューター内のみで簡易的に使用する場合の、2種類の接続パターンがあります。

■楽器とコンピューターを接続して使用する

本アプリ推奨の使い方です。

接続イメージ

コンピューターと楽器の接続方法については、楽器の取説をご覧ください。

楽器に接続するとできること：
• MIDIソングの再生音：楽器に発音させる
• 変換後のスタイル試聴：楽器に発音させる
• 変換後のスタイルファイルを楽器に直接保存 (転送) する
• 変換後のスタイル試聴時に、楽器の鍵盤でコード指定する

必要な設定：
アプリ上部のメニューから[Preference] -> [MIDI Device]を開き、下記のようにポートを設定します。
• MIDI Input Device : 楽器のMIDI Out
• MIDI Output Device : 楽器のMIDI In

NOTE
本アプリ上で試聴するときに楽器からコード指定する場合、楽器の[ACMP]はオフにしてください。
(楽器に変換後のスタイルファイルを読み込んで使う場合は、通常通り[ACMP]はオンにします。)

NOTE
ファイル転送のために、InputとOutputの両方とも、楽器に設定されている必要があります。

コンピューター

楽器
楽器の
スピーカー

USBケーブルMIDI Output Device

MIDI Input Device
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ご使用前の準備
■コンピューター内のみで、簡易的に使用する

楽器とコンピューターをつながなくても、アプリケーション単体で簡易的に使用できます。
音色などの再現性は低くなりますが、コンピューターのみで作業できます。

接続イメージ

コンピューター内のみでできること：
• MIDIソングの再生音： アプリケーション内部のソフトシンセで発音する(*1)
• 変換後のスタイル試聴： アプリケーション内部のソフトシンセで発音する (*1)
• 変換後のスタイルファイルはコンピューター内に保存する。USBメモリーを使って楽器に渡す
• 変換後のスタイル試聴時は、アプリ内のコードパレット(13ページ)でコード指定する
*1) 音の再現性には限界があります。

必要な設定：
アプリ上部のメニューから[Preference] -> [MIDI Device]を開き、下記のようにポートを設定します。
• MIDI Input Device : なし (MIDIキーボードなどがあれば設定する)
• MIDI Output Device : 「MIDI Song to Style Synth」 + 音を鳴らしたいオーディオデバイス 

コンピュータ
内部のオーディオ
デバイス

コンピューターの
スピーカー

内蔵
ソフトシンセ

MIDIキーボードなど

コンピューター

MIDI Output Device

MIDI Input Device
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ご使用前の準備
■音色リストをインポートする

本アプリで読み込んだMIDIソングの各Chの音色を変更するとき(25ページ)には、アプリ内の音色リストの中から音色を選択
できます。初期のリストはGenos2 ファームウェアバージョン1.00の音色リストになっています。
音色リストをインポートすると、このアプリ内の音色リストを、連携する楽器のものと合わせることができます。
MIDI Song to Style用の音色リストファイルは、対応している製品の場合、
ヤマハウェブサイト(https://www.yamaha.com/)内の製品ページに情報があります。

1. アプリ上部のメニューで[Edit] -> [Import Voice List]を選択します。
ファイル選択ウインドウが開きます。

2. お使いの楽器の音色リスト(.txt)を選びます。
アプリ内の音色リストが、読み込んだリストに更新されます。
エラーメッセージが出なければ、読み込み完了です。
5



クイックガイド/オーバービュー
MIDI Song to Styleの使い方

■一番シンプルな使い方: 変換して転送する

1. MIDI Song to StyleにSMFファイルをドラッグ&ドロップします。

MIDIソングが自動で分析され、スタイルに変換されます。
このとき、アプリ上で変換後のスタイルを再生、編集できます(16ページ)。

2. 分析してできた結果をスタイルファイルとして、楽器に転送します。( アイコンをクリックする)
次のように2通りの方法があります。
A) USBケーブル接続で楽器にスタイルファイルを直接保存する (Save to Instrument)
(コンピューターと楽器をUSBケーブルで接続しているとき使えます。設定方法については3ページを参照してく
ださい。)

B) スタイルファイルとしてUSBメモリーに保存し、ファイルを楽器に渡す (Save to Computer)

3. 転送したスタイルを使って、楽器を演奏します。

1 2

コンピューター

MIDI Song to Style

MIDIソング
(.mid)

スタイル
(.sty)

USBケーブル接続
での転送
または

USBメモリー経由

楽器

MIDIソングファイル
スタンダードMIDIファイル形式

(.mid)
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クイックガイド/オーバービュー
■条件を変更して再分析する

スタイルの自動変換結果が望むものになっていない場合、分析の条件を変更して、再変換できます。
• 主旋律のチャンネルや、スタイルに含めたくないチャンネルを設定する (19ページ)

■自動変換されたスタイルを調整する

自動変換後のスタイルを、手動で調整できます。
• セクションとしてMIDIソングから抽出する範囲を変更する (20ページ)
• セクションの順番を入れ替える (21ページ)
• 新しい範囲を選択して、セクションに割り当てる (22ページ)
• セクションごとの、各スタイルパートへのMIDIチャンネルの割り当てを変更する (24ページ)
• MIDIソングの各チャンネルの音色を変更する (25ページ)
• スタイルの各パートの音量を変更する/リセットする (26ページ)
• スタイルの拍を変更する (26ページ)
7



クイックガイド/オーバービュー
編集中のデータ(プロジェクト)を保存する/読み込む
読み込んだMIDIソングや分析した情報、編集した内容も含め、プロジェクトファイルとして専用のファイル形式(.sts)に保存
/読み込みできます。

プロジェクトファイルには、以下の内容が保存されます。
• 読み込んだMIDIソング(SMFファイル)の内容
• MIDIソングの自動分析結果
• セクションやパート割り当てなど、スタイルの編集状態

■プロジェクトを保存する

アプリ上部のメニューで [File] -> [Save Project]を開き、保存先を指定します。

■プロジェクトを読み込む

アプリ上部のメニューで [File] -> [Open Project]を開き、プロジェクトファイルを選びます。
または、アプリにプロジェクトファイルをドラッグ&ドロップします。
8



各部の機能(画面説明)
画面の遷移
アプリを起動した後の大まかな画面の遷移を下図で確認できます。

起動時

MIDI設定

その他設定

ホーム（Easy）

コードパレット（別ウィンドウ）

ホーム（Edit）

スタイル保存

Detail Edit （別ウィンドウ）
セクションパラメーター編集

ファイル読み込み

モード切り替え
9



各部の機能(画面説明)
各画面の機能
この章では、各画面でできることについて説明します。

■ホーム画面(Easy)

q MIDIソングの再生をコントロールする

w新ファイルを読み込むための画面を開く

eホーム画面のモードを切り替える (Easy ⇔ Edit)

r MIDI設定画面を開く (12ページ)

tその他設定画面を開く (12ページ)

y変換後のスタイルを再生する (16ページ)

uスタイル再生時の指定コードの表示/コードパレット画面を開く (13ページ)

iスタイルの保存画面を開く (18ページ)

q

t

y

e

r

w

u

i
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各部の機能(画面説明)
■ホーム画面(Edit)

q～i ホーム画面(Easy)と同じです。

o自動分析の設定を変更して、再分析する (19ページ)

!0 MIDIソング再生の各チャンネルの確認、操作
• 音色の大まかなタイプを表示する(表示のみ)
• 各チャンネルのオン/オフ(ミュート)を設定する

!1 MIDIソングのデータ概形表示、スタイルセクションの編集
• MIDIソングの各チャンネルのデータ概形表示 (表示のみ)
• スタイルセクションの編集(20ページ)
• 各スタイルパートへのMIDIチャンネル割り当ての変更 (24ページ)

!2 MIDIソングのデータ概形表示(!1)の拡大率変更

!3スタイルの各種設定表示/変更 (17、26ページ)
• テンポ (表示のみ)
• 拍子(Beat, Time Signature)
• 各スタイルパートのオン/オフ、音量
• セクションキー

!3

u

!1

!2

t

y

r

e

!0

qo wi
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各部の機能(画面説明)
■MIDI設定画面

q MIDI インプットデバイスを設定する

w MIDI アウトプットデバイスを設定する
「MIDI Song to Style Synth」を選ぶ場合は、さらに音声の出力先も設定します。

e MIDIデバイスのリストを更新する

■その他設定画面

q変換後のスタイルファイルの最大サイズを設定する

wコードパレットウインドウ(13ページ)を、スタイル再生時に自動で呼び出すかどうかを設定する

eこのアプリの利用状況について、匿名データとしての収集を許可するかどうかを設定する

w

q

e

q

w

e
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各部の機能(画面説明)
■コードパレット ウインドウ

スタイル再生時のコードを指定するためのウインドウです。

qコードのルートを指定する

wコードのタイプを指定する
「cc」は「コードキャンセル」(コードの指定がない状態)です。

e On Bassコードの有効/無効、ベース音の指定をする

r指定した結果のコード表示

e

w

r

q
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各部の機能(画面説明)
■Detail Edit ウインドウ

MIDIソングのチャンネル設定の編集や、スタイルセクション内の各パートの詳細設定の変更ができるウインドウです。

q MIDIソングの再生をコントロールする

w MIDIチャンネルのオン/オフ(ミュート)を設定する

e MIDIチャンネルの設定をリセットする
未編集の状態にリセットします。

r MIDIチャンネルの音色を設定する
プログラムチェンジ番号での設定、または音色名での設定ができます。
音色名での設定には、インポートされた音色リスト(5ページ)が使われます。
音色番号または音色名の色は、下記の意味です。

t MIDIチャンネルの音量を設定する

白 未編集、かつシーケンスの途中で音色が変化しない。

黄色 未編集、かつシーケンスの途中で音色が変化する。

オレンジ 音色が手動で設定された。

ew r q

i u t y
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各部の機能(画面説明)
y MIDIチャンネルの音量の状態表示
音量の状態は、下記の3種類で表示されます。

u全MIDIチャンネルの設定をリセットする

i各チャンネルのセクションへの割り当て状況の表示、スタイルパート詳細設定の呼び出し
各チャンネルが、スタイルの各セクションにどのパートとして割り当てられているかを表示しています。
略称の詳細は以下のとおりです。

セクション名

スタイルパート名

また、各スタイルパート名のところをクリックすると、各セクション内のパートについて、詳細パラメーターを編集できま
す。
詳細パラメーターについて詳しくは、29ページをご覧ください。

白 未編集、かつシーケンスの途中で音量が変化しない。

黄色 未編集、かつシーケンスの途中で音量が変化する。

オレンジ 音量が手動で設定された。

I1～I3 Intro I～III

MA～MD Main A～D

FA～FD Fill In A～D

BK Break

E1～E3 Ending I～III

R1、R2 Rhy1、Rhy2

Bs Bass

C1、C2 Chd1、Chd2

Pd Pad

P1、P2 Phr1、Phr2

NOTE
詳細パラメーターは分析結果に合わせて自動で設定されるため、通常は編集不要です。
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詳しい使い方
変換後のスタイルを再生(試聴)する
変換後のスタイルについて、コードも指定しながら、どう再生されるかを試すことができます。

■スタイルを再生する

1. 再生したいセクションのアイコンをクリックします。

セクションのアイコンが再生中の表示(反転表示)になり、セクションがループ再生されます。

この例では、Main Bを再生しています。
また、初期設定では、コードパレットウインドウ(13ページ)が自動で呼び出されます。

2. セクションの変更や、コードの指定など、スタイルの再生をコントロールします。
• ほかのセクションのアイコンをクリックすると、そのセクションが再生されます。
• コードパレットウインドウかMIDI Input Deviceに設定した楽器からコードを指定して、音の変化を確認できます。

3. 再生中のセクションのアイコンをクリックすると、スタイル再生が停止します。

セクションのループ再生オン/オフを設定する
本アプリのデフォルト設定では、スタイルの内容確認のために、どのセクションもループ再生されます。これは楽器とは異
なる動作です。
Intro I～III、Fill In A～D、Break、Ending I～IIIのセクションに関してループ再生しないように変更したい場合は、アイ

コン右上の マークをクリックしてください。表示が (ループオフ)に変化し、これらのセクションが、楽器と同様に

一度だけ再生され、本来の移行先に移行するようになります。
16



詳しい使い方
■再生時の各スタイルパートをオン/オフする

ホーム画面(Edit)では、各パートのオン/オフ(ミュート)の変更ができます。

スタイルパート名の部分をクリックすると、パートのオン/オフを切り替えることができます。

オフになったパートはグレーアウト表示されます。

この例では、Chd1とChd2をオフにしています。
17



詳しい使い方
変換後のスタイルを保存、転送する
変換結果をスタイルファイル(.sty)として、コンピューター内に保存、または接続された楽器に転送します。

1. アイコンをクリックします。

2. ファイルの保存方法を選びます。
• [Save to Instrument]: 楽器にスタイルファイルを直接転送・保存します。 

ファイルはUserドライブのルートフォルダーに保存されます。
• [Save to Computer]: コンピューター内にスタイルファイルを保存します。

3. 画面の案内に従って、保存・転送します。
A) [Save to Instrument] (楽器に直接転送する)の場合

名前を入力して、[Save to Instrument]をクリックすると、転送が始まります。
B) [Save to Computer] (コンピューター内に保存する)の場合
ファイルの保存ダイアログが呼び出されるので、名前を入力してお好みの場所に保存します。
楽器に転送するときは、USBフラッシュドライブを使います。

NOTE
保存をキャンセルしたいときは、もう一度 アイコンをクリックします。

NOTE
[Save to Instrument]は、コンピューターと楽器をUSBケーブルで接続しているときのみ使えます。設定方法については3ページ
を参照してください。
18



詳しい使い方
自動分析の事前設定を変更する
MIDIソングの分析条件は自動で設定されますが、思わしくない結果になる場合もあります。
各チャンネルを分析に含むかどうかの設定を変更して、再分析できます。

■分析から除外するチャンネルを手動で指定して、再分析する

1. ホーム画面をEditモードにします。

2. [Reanalyze Setting]をクリックします。

分析設定の画面が呼び出されます。

3. チャンネル除外の設定を変更します。

[Melody]タブと[Assign]タブそれぞれ、目的に応じてチェックマークを編集します。
• [Melody]タブ：チェックされているチャンネルは「主旋律扱い」になります。

主旋律扱いのチャンネルは、セクション範囲の推定に使われます。
[Melody]タブでチェックを入れたときに、自動的に[Assign]タブのチェックが外れます。
初期値では、自動で主旋律を判別した結果が反映されています。
主旋律として指定したいチャンネル(例えば、自分自身で弾きたい音を含むチャンネル)のチェックを
入れます。

• [Assign]タブ: チェックされているチャンネルは、スタイルパートに割り当て可能なパートです。
特定のチャンネルの演奏音を変換後のスタイルに含めたくない場合、チェックを外します。

4. [Reanalyze]をクリックして、再分析を実行します。
変換結果が更新されます。
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詳しい使い方
変換後のスタイルを編集する
ホーム画面のEditモード(11ページ)で、自動変換後のスタイルに手を加えて、自分の望む変換結果に近づけることができま
す。

■セクションの範囲を変更する

1. 画面上部のセクション名をクリックして、範囲を変更したいセクションを選びます。

選んだセクションが反転表示されます。例では、Intro IIを選んでいます。

2. セクションの範囲の右端か左端をドラッグします。

セクションの範囲が変更されます。

NOTE
この章で紹介する編集操作は、アプリ上部メニューの[Edit] -> [Undo]/[Redo]で戻したり、やり直したりできます。
20



詳しい使い方
■セクションの順番を入れ替える

セクションの自動割り当て結果が使いたい順番でない場合、セクションを入れ替えることができます。

1. 画面上部のセクション名をクリックして、入れ替え元のセクションを選びます。

選んだセクションが反転表示されます。例では、Main Dを選んでいます。

2. 選択済みのセクション名をもう一度クリックします。

セクション割り当てのポップアップが呼び出されます。

3. 入れ替え先のセクション名を選択し、[Assign]をクリックして決定します。

セクションの割り当てが変更されます。例では、Main AとMain Dが入れ替わりました。

NOTE
MainセクションとFill Inセクションはセットで入れ替えると、自然さを維持できます。
たとえばMain Bと Main Cを入れ替えたとき、Fill BとFill Cも入れ替えると、対応関係を維持できます。
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詳しい使い方
■セクションを新しく(手動で)割り当てる

好きな範囲を指定して、新しくセクションを割り当てることができます。

1. 割り当てたい範囲を画面内で選択します。

選択された範囲が表示されます。

2. をクリックします。

セクション割り当てのポップアップが呼び出されます。

3. 選択範囲を割り当てたいセクション名を選択し、[Assign]をクリックして決定します。
• 既存の割り当てがないセクションを選んだ場合：セクションが新しく追加されます。
• 既存の割り当てがあるセクションを選んだ場合：既存のセクションは削除され、新しい範囲に置き換わります。

例では、選択範囲がIntro Iとして新しく追加されました。
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詳しい使い方
■セクションを削除する

不要なセクションを削除できます。

1. 削除したいセクション名を右クリックします。

削除メニューが表示されます。

2. [Delete <セクション名>]をクリックします。
セクションが削除されます。
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詳しい使い方
■セクション内パートとMIDIチャンネルの組み合わせを変更する

セクションごとに、どのMIDIチャンネルがどのスタイルパートに変換されるかの割り当てを変更できます。

1. 画面上部のセクション名をクリックして、編集するセクションを選びます。

選択されたセクション内の、各パートへのチャンネル割り当て状況が表示されます。

2. 割り当てを変えたいパートを、ドラッグ&ドロップします。

ドラッグ元とドラッグ先のパートが入れ替わります。

セクション内のパート削除、追加
パート名の横にある[-]アイコンをクリックすると、パートの割り当てを削除できます。

セクションの範囲内に演奏データがある未割り当てのチャンネルには、[+]アイコンが表示されます。

[+]アイコンをクリックすると、セクションパートを選んで割り当てることができます。
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詳しい使い方
■ソングの各チャンネルの音色を変更する(Detail Edit)

MIDIソング内で指定されている汎用的な音色から、楽器に独自に入っているリッチな音色に変更できます。

1. アプリ上部のメニューから、[Edit] -> [Open Detail Edit Window]を選びます。
Detail Editウインドウが呼び出されます。

2. 各チャンネルの音色設定を変更します。

プログラムチェンジ番号での設定、または音色名での設定ができます。
音色名での設定には、インポートされた音色リスト(5ページ)が使われます。
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詳しい使い方
■スタイルの各パートの音量を変更する/リセットする

全セクションを通しての各スタイルパートの音量を変更できます。

スタイルパート名の下にあるノブを操作して、各パートの音量を調節できます。
数値を直接編集することもできます。

変更した音量を初期状態(MIDIソング読み込み時の状態)にリセットしたいときは、下記のどちらかを実行します。
• アプリ上部のメニューから、[Edit] -> [Reset Style Parameter] -> [Volume]を開き、リセットしたいパートを選ぶ
• CTRLキー (Windows)またはCommandキー (Mac)を押しながら、リセットしたいパートに対応するノブをクリックする

また、変更操作のひとつ前に戻した場合は、[Edit] -> [Undo]を選びます。

■スタイルの拍(Beat, Time Signature)を変更する

変換後のスタイルの拍(Time Signature)の設定を変更できます。

画面下部分の「Beat」エリアをクリックして、値を設定します。

■スタイルのセクションキーを変更する

セクションキー (Section Key Signature)は、各セクションがどのキーを基準として演奏データを持つか、のパラメーターで
す。
Intro、Endingセクションは、このキーと同じルート音でコード指定を受けたときに、変換前のMIDIソングと同じ高さで演奏
されます。
画面上部で変更したいセクション名を選択してから、画面下部分の「Section Key」エリアをクリックして、値を設定しま
す。
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付録
基礎知識解説

■MIDIソング (SMF)

• 電子的な楽譜データです。対応している機器に読み込むと、音楽を再生できます。
• 別々の音色 (楽器音)や音量、演奏内容を指定できる「チャンネル」を16個内包しています。
• SMF (Standard MIDI File) (.mid)は、MIDIファイルの標準的なフォーマットの名前です。

■スタイル関連用語
セクション:
音楽の進行に対応するまとまりです。
演奏の進行に応じて、自動で切り替わったり、手動で切り替えたりします。
Intro I-III、Main A-D、Fill A-D、Break、Ending I-IIIがあります。

再生例:

パート：
セクション内の構成要素です。個別に音色などを設定できます。MIDIソングのチャンネルに相当します。
Rhythm1-2、Bass、Chord1-2、Pad、Phrase1-2があります。

スタイルファイル: 
「スタイルファイルフォーマット(SFF)」は、ヤマハの自動伴奏機能(伴奏スタイル)に関するフォーマットです。フォーマット
には、SFFと、SFF GEの二種類があります。
SFF GE(ギターエディション)は、ギターの表現力をさらに高めた、SFFの拡張フォーマットです。
MIDI Song to Styleは、SFF GEフォーマットでスタイルファイルを書き出します。

NOTE
MIDI Song to Styleでの自動変換では、一部のセクション (Intro I、Break、Ending I、Ending III)は必ず割り当てなしになります。 

操作

スタイル再生

INTRO
［I］

START/
STOP

MAIN
［Ｂ］

ENDING
［II］

停止Intro I
（1回）

Main A
（ループ）

Fill In B
（1回）

Main B
（ループ）

Ending II
（1回）

Main A

Rhythm 1

Rhythm 2

Bass

Chord 1

Chord 2

Pad

Phrase 1

Phrase 2

Main B

Rhythm 1

Rhythm 2

Bass

Chord 1

Chord 2

Pad

Phrase 1

Phrase 2
27



付録
メニュー一覧

* Mac版の場合は、「MIDI Song to Style」アプリのメニュー内にあります。 

メニュー 説明

File Open SMF　 MIDIソングファイル(.mid、.midi)を読み込みます。

Save Style File 変換後のスタイルファイルをコンピューターに保存します。

Open Project プロジェクトファイル(.sts)を読み込み、保存時の編集状態を再現します。

Save Project 編集中のプロジェクトを、独自形式のプロジェクトファイル(.sts)に保存します。

Recent Files 最近開いたファイルを選びます。

Exit (Quit)* アプリを終了します。

Edit Undo 編集状態を1ステップ前に戻します。

Redo 編集状態を戻したものを、1ステップ先に進めます。

Open DetailEdit Window DetailEditウインドウを開きます。

Import Voice List 音色リストをインポートします。

NOTE
音色リストは、DetailEditウインドウで音色指定をするときに使います。

Reset Style Parameter Volume スタイルの各パートの音量をリセットします。

Help Manual 取扱説明書(本書)を表示します。

Privacy Statement プライバシーポリシーを表示します。

About* アプリのバージョンやコピーライトを表示します。
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付録
キーボードショートカット一覧

Detail Edit ウインドウ: セクションパラメーターの編集
セクションパラメーターの編集ウインドウは、Detail Editウインドウ (14ページ)でセクション内のパートをクリックしたと
きに呼び出されます。

操作 ショートカット

MIDIソングファイル(.mid)読み込み Ctrl + Shift + O

Style ファイル(.sty)の保存 Ctrl + Shift + S

プロジェクトファイル(.sts)の読み込み Ctrl + O

プロジェクトファイル(.sts)の保存 Ctrl + S

Undo Ctrl + Z

Redo Ctrl + Shift + Z

DetailEdit画面を開く Ctrl + Shift + D

MIDIソングの再生/停止 スペース

NOTE
• キーボードで数字入力をした直後、キーボードショートカットが使えない場合があります。その場合は、画面のどこかを一度クリッ
クすると、使えるようになります。
• Macの場合は、CtrlをCommandに読み替えてください。
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付録
■画面内各項目の詳細

項目名 説明

Section 
Setting

→ どのセクションについて編集するか、を切り替えます。
この項目のみ、通常時とセクション名の表示が異なります。下記の形で読み替
えてください。
• Intro A-C： Intro I-III
• Fill in AA-DD： Fill In A-D
• Fill in BA： Break
• Ending A-C： Ending I-III

Key Signature セクションの調 (Section Key Signature)を設定します。

Channel 
Setting

→ 選択中のセクション内で、どのMIDIチャンネルについて編集するか、を切り替
えます。

Attribute チャンネルの属性(自動分析の結果)を表示します。

Style Part 選択中のチャンネルの、セクション内でのパート割り当てを表示します。

Zone Setting → セクション範囲内の上記チャンネル(に割り当てられたスタイルパート)につい
て、エリアの分割と動作設定をします。

Lo Zone Split Lo ZoneとMain Zoneをどこで分けるかを設定します。
入力するのは、Main Zoneの最低鍵の値(-, 1～127)です。
"-"の場合、Lo Zone内の設定は無効になります。

Style Playing 
Parameter

Lo ZoneのStyle Playing Parameterを表示します(自動設定、編集不可)。

Convert to Style 
Parameter

Lo Zoneの、スタイルに変換するときのノート変換ルールを設定します。
選択肢は 下記の４つです。
RootOnly、Active for Main、Semi-active Bass、-

HiKey 
(High Key)

Lo Zoneについて、スタイル再生時にトランスポーズを上下どちらの方向にす
るかを切り替える基準値(0～11: C～B)を設定します。
再生時、この値より高い音がコードルートに指定されたときに、トランスポー
ズが下方向になります。

LoLim 
(Low Limit)

Lo Zoneについて、スタイル再生時のトランスポーズの最小値(0～127)を設定
します。
再生時、トランスポーズの計算結果がこの値より小さい数になったときは、
Style Playing Parameterに応じて、オクターブ折り返しや発音停止などの動作
をします。

HiLim 
(High Limit)

Lo Zoneについて、スタイル再生時のトランスポーズの最大値(0～127)を設定
します。
再生時、トランスポーズの計算結果がこの値より大きい数になったときは、
Style Playing Parameterに応じて、オクターブ折り返しや発音停止などの動作
をします。
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付録
Zone Setting Main Zone Style Playing 
Parameter

Main ZoneのStyle Playing Parameterを設定します。

Convert to Style 
Parameter

Main Zoneの、スタイルに変換するときのノート変換ルールを設定します。

HiKey 
(High Key)

Main Zoneについて、スタイル再生時にトランスポーズを上下どちらの方向に
するかを切り替える基準値(0～11: C～B)を設定します。
再生時、この値より高い音がコードルートに指定されたときに、トランスポー
ズが下方向になります。

LoLim 
(Low Limit)

Main Zoneについて、スタイル再生時のトランスポーズの最小値(0～127)を
設定します。再生時、トランスポーズの計算結果がこの値より小さい数になっ
たときは、Style Playing Parameterに応じて、オクターブ折り返しや発音停止
などの動作をします。

HiLim 
(High Limit)

Main Zoneについて、スタイル再生時のトランスポーズの最大値(0～127)を
設定します。再生時、トランスポーズの計算結果がこの値より大きい数になっ
たときは、Style Playing Parameterに応じて、オクターブ折り返しや発音停止
などの動作をします。

Hi Zone Mega Voice Hi Zone (C6以上)のノートに対して、MegaVoice用の処理をするかどうかを
設定します。
チェックを入れると、C6以上のノートは変換されることがなくなり、
MegaVoiceを使うときに正しく演奏される状態が維持されます。

項目名 説明
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付録
■Style Playing Parameterについて

スタイル再生時に、セクションの各パートがコード指定に対応するためのノート変換ルールです。
特性に合ったものを選択すると、演奏が破綻しにくくなります。

■Convert to Style Parameterについて

チャンネル内のノートを、スタイルのパート内のノートに変換するときのルールです。

プリセット名 説明

Bass Main/FillのBassパート用

Bass (Intro) Intro/EndingのBassパート用

Chord Main/Fillの、複音の和音が主体のパート用

Phrase chordal Main/Fillの、単音の分散和音（アルペジオなど）が主体のパート用

Phrase melodic Main/Fillの、単音のメロディックなフレーズが主体のパート用

Guitar Stroke Main/Fillの、複音の和音(コードストロークなど)が主体のギターのパート用

Guitar Arpeggio Main/Fillの、単音の分散和音（アルペジオなど）が主体のギターのパート用

Chromatic Main/Fillの、半音階フレーズが主体のパート用

Maj-min (Intro) Intro/Endingの、BassやRhy1-2以外のパート用

Drum with cymbal Crash Cymbalありのドラムキットを使うパート用

Drum no cymbal Crash Cymbalなしのドラムキットを使うパート用

SFX SFXキットを使うパート用

- アサインなし（パートアサインがない場合）

NOTE
Bass (Intro)、またはMaj-min(Intro)を設定したパートは、セクションキーの影響を強く受けます

プリセット名 説明

no change ノートをそのまま使います。

Root only コードルートのみが再現されます。

Root & 5th コードルートと5度音のみが再現されます。

Semi-active Bass ある程度オリジナルの動きが再現されます。
スタイル再生中のコード指定に対する安定性（聞きやすさ）は、
「Root Only」と比べると劣る場合もあります。

Stable for Main スタイル再生中のコード指定に対して、複音和音の安定した再生が
可能です。
しかし、オリジナルの動きは再現されないこともあります。

Active for Main 分析時のコード分析結果が適切な場合、オリジナルの動きがよく再
現されます。
コード分析結果に誤りがあった場合は、変換後のスタイルが聞き苦
しくなる可能性があります。

Guitar Stroke 「Guitar Stroke」専用の設定です。

Guitar Arpeggio 「Guitar Arpeggio」専用の設定です。
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付録
■Convert to Style Parameterの選択肢に関する制約

Style Playing Parameterの設定に応じて、Convert to Style Parameterの選択肢が変わります。
下の表の通りです。

Style Playing Parameter

Bass Bass 
(Intro)

Chord Phrase 
chodal

Phrase 
melodic

Guitar 
Stroke

Guitar 
Arpeggio

Chromatic, 
Maj-min(Intro), 
Drum with cymbal, 
Drum no cymbal, 
SFX

Convert to Style 
Parameter 

no change ○ ○

Root only ○ ○ ○

Root & 5th ○ ○

Semi-active 
Bass ○

Stable for 
Main ○ ○ ○

Active for 
Main ○ ○ ○ ○

Active root 
only ○ ○

Active root & 
5th ○ ○

Guitar Stroke ○

Guitar 
Arpeggio ○
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付録
困ったときは
正常に動作しないと思った場合、下記の事項をご確認ください。

現象 原因 解決法

楽器に接続しているのに、楽器に直接ファ
イルを保存(転送)できない。

MIDI Input/Output Deviceのどちらか、ま
たは両方に楽器が設定されていません。

SettingのMIDI Input/Output Device両方に
接続した楽器を設定します。

楽器に接続しているのに、スタイル試聴中
の和音(コード)を楽器から指示できない。

楽器側の[ACMP]がオンになっています。
[ACMP]がオンだと、コード情報は楽器の
中にのみ送られ、コンピューターには送ら
れません。

楽器の[ACMP]をoffにします。 

アプリの画面がブラックアウトする。 ウインドウを最大化して使っています。最
大化状態で使用すると、OSの処理との兼ね
合いで、別ウインドウの表示が崩れること
があります。

• [ESC]キーを押してウインドウの最大化を
キャンセルします。
• ウインドウを最大化せずにアプリを使用し
ます。
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